You need the following libraries to successfully compile Kismet:

./configure --enable-airpcap

Install from PPA

You can also install the latest version using aptitude from Festor's HackTools PPA.